Recent Activity

Activity stream for all registered members at MB Medic Forum.

  1. engineer replied to the thread My E350 is completely dead....

    Look in the engine bay there should be a positive lead that powers up the car if you connect a jump box to it. It is used to jump start...

    Jan 18, 2017 at 8:33 PM
  2. engineer replied to the thread instrument cluster not working.

    It could be a burned light bulb. I would take the cluster out again and check the SRS light bulb. Have you tried that?

    Jan 18, 2017 at 5:27 PM
  3. engineer replied to the thread C-Class air suspension.

    Yes they can. But what does that have to do with air suspension?

    Jan 18, 2017 at 5:26 PM
  4. engineer replied to the thread 2000 ML 320.

    Does it happen after you press the brakes? Try to pay attention to that next time and let us know.

    Jan 18, 2017 at 5:25 PM
  5. engineer replied to the thread 2003-2009 (W211) W211 - check component R39/1 and Rail pressure to high.

    How is the engine running? Do you notice any shaking? Any misfire codes present?

    Jan 18, 2017 at 5:24 PM
  6. engineer replied to the thread 2008-____ (W204) car cranking but no start with all warning signs showing up..

    You may have a CAN network communication issue or a bad sam module. A star diagnostic scanner may be able to connect to the different...

    Jan 18, 2017 at 5:23 PM
  7. engineer replied to the thread 1994-2000 (W202) Radio Code.

    Some MB dealers will give you the code even if you don't go there. Just call a two or three dealers anywhere in the country. One of them...

    Jan 18, 2017 at 5:19 PM
  8. engineer replied to the thread Transmission.

    Have you checked the 13 pin connector?

    Jan 17, 2017 at 6:26 PM
  9. engineer replied to the thread My E350 is completely dead....

    Have you tried opening the trunk with the metal key blade that is inside the key fob? Manually open it not with the keyfob.

    Jan 17, 2017 at 4:39 PM
  10. engineer replied to the thread 1994-2000 (W202) Hard to start at medium temperatures.

    That's great news. Thank you for coming back and updating the post. Someone will find it helpful one day.

    Jan 16, 2017 at 8:38 PM
  11. engineer replied to the thread E420 Crank but won't start.

    Check to see if the fuel pump is getting power. Have you done that?

    Jan 16, 2017 at 8:37 PM
  12. engineer replied to the thread Ml 320 check engine rough idle.

    I think it is just a coincidence that the problem happened after you filled it up while running. Change the oxygen sensor but it is...

    Jan 16, 2017 at 8:35 PM
  13. engineer replied to the thread SLK 2015 NON START AFTER CRASH.

    Have you tried to turn the crankshaft by hand?

    Jan 16, 2017 at 8:33 PM
  14. engineer replied to the thread Readar.

    Have someone press and hold down the hood while you pull on the release. Pull the hood release and keep it pulled. Have your friend...

    Jan 16, 2017 at 10:28 AM
  15. engineer replied to the thread Wiper Ml 320 CDI.

    Take a look at this article: http://www.mercedesmedic.com/mercedes-windshield-wiper-problem/ Any recent work on the car?

    Jan 16, 2017 at 10:26 AM
Loading...